import re
regex = re.compile(r"^isCellValueEqualTo\(('[0-9]+\.[0-9]+'), ('CashValue')\);$", flags=re.DOTALL)
test_str = "isCellValueEqualTo('100.00', 'CashValue');"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)