re = /^isCellValueEqualTo\(('[0-9]+\.[0-9]+'), ('CashValue')\);$/
str = 'isCellValueEqualTo(\'100.00\', \'CashValue\');'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result