const regex = /"[^"]*"(*SKIP)(*F)|\b100\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]*"(*SKIP)(*F)|\\b100\\b', 'gm')
const str = `<p alt="100">100</p>
<img src="100.jpg">100</ing>
<span alt="tel:100">100</span>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);