import Foundation
let pattern = #""[^"]*"(*SKIP)(*F)|\b100\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p alt="100">100</p>
<img src="100.jpg">100</ing>
<span alt="tel:100">100</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)