use strict;
my $str = '<p alt="100">100</p>
<img src="100.jpg">100</ing>
<span alt="tel:100">100</span>
';
my $regex = qr/"[^"]*"(*SKIP)(*F)|\b100\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";