import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(.+?)(\\.css).*?\"";
final String string = "<link rel=\"stylesheet\" type=\"text/css\" href=\"css/site_global.css?366877458\"/>\n\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"css/master_trimestre.css?4021764086\"/>\n\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"css/eltrimestre.css?3970103658\" id=\"pagesheet\"/>";
final String subst = "href=\"{{ asset(\"static/$1$2\") }}\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}