// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href="(.+?)(\.css).*?""#).unwrap();
let string = "<link rel=\"stylesheet\" type=\"text/css\" href=\"css/site_global.css?366877458\"/>
<link rel=\"stylesheet\" type=\"text/css\" href=\"css/master_trimestre.css?4021764086\"/>
<link rel=\"stylesheet\" type=\"text/css\" href=\"css/eltrimestre.css?3970103658\" id=\"pagesheet\"/>";
let substitution = "href=\"{{ asset(\"static/$1$2\") }}\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}