import Foundation
let pattern = #"href="(.+?)(\.css).*?""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<link rel="stylesheet" type="text/css" href="css/site_global.css?366877458"/>
<link rel="stylesheet" type="text/css" href="css/master_trimestre.css?4021764086"/>
<link rel="stylesheet" type="text/css" href="css/eltrimestre.css?3970103658" id="pagesheet"/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"href="{{ asset("static/$1$2") }}""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)