const regex = /href="(.+?)(\.css).*?"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="(.+?)(\\.css).*?"', 'g')
const str = `<link rel="stylesheet" type="text/css" href="css/site_global.css?366877458"/>
<link rel="stylesheet" type="text/css" href="css/master_trimestre.css?4021764086"/>
<link rel="stylesheet" type="text/css" href="css/eltrimestre.css?3970103658" id="pagesheet"/>`;
const subst = `href="{{ asset("static/$1$2") }}"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);