const regex = /^((?:turn (?:on|off))|toggle) (\d+),(\d+) through (\d+),(\d+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:turn (?:on|off))|toggle) (\\d+),(\\d+) through (\\d+),(\\d+)$', '')
const str = `turn off 0,0 through 999,999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}