re = /^((?:turn (?:on|off))|toggle) (\d+),(\d+) through (\d+),(\d+)$/
str = 'turn off 0,0 through 999,999'
# Print the match result
str.match(re) do |match|
puts match.to_s
end