$re = '/^((?:turn (?:on|off))|toggle) (\d+),(\d+) through (\d+),(\d+)$/';
$str = 'turn off 0,0 through 999,999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);