using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s* ( \[some_element\] ( (?: .* | (?1) )* ) \[/some_element\] ) ";
string input = @"[some_element]Random string chars [some_element]Ramdon[/some_element] some more random chars[/some_element]";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}