import Foundation
let pattern = #"\s* ( \[some_element\] ( (?: .* | (?1) )* ) \[/some_element\] ) "#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"[some_element]Random string chars [some_element]Ramdon[/some_element] some more random chars[/some_element]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}