re = /\s* ( \[some_element\] ( (?: .* | (?1) )* ) \[\/some_element\] ) /x
str = '[some_element]Random string chars [some_element]Ramdon[/some_element] some more random chars[/some_element]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end