package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s* ( \[some_element\] ( (?: .* | (?1) )* ) \[/some_element\] ) `)
var str = `[some_element]Random string chars [some_element]Ramdon[/some_element] some more random chars[/some_element]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}