#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[^>]+(?=<\/a>)"
Local $sString = "<a href="http://google.com">Google</a>" & @CRLF & _
"<a href="http://apple.com" title="Apple, Inc.">Apple</a>" & @CRLF & _
"<a title="Microsoft, Inc." href="http://microsoft.com">Microsoft</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")