import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^>]+(?=<\\/a>)";
final String string = "<a href=\"http://google.com\">Google</a>\n"
+ "<a href=\"http://apple.com\" title=\"Apple, Inc.\">Apple</a>\n"
+ "<a title=\"Microsoft, Inc.\" href=\"http://microsoft.com\">Microsoft</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}