$re = '/[^>]+(?=<\/a>)/mi';
$str = '<a href="http://google.com">Google</a>
<a href="http://apple.com" title="Apple, Inc.">Apple</a>
<a title="Microsoft, Inc." href="http://microsoft.com">Microsoft</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);