#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[.!?]\s*[a-z]"
Local $sString = "Howdy world? lorem // match" & @CRLF & _
"Howdy world... lorem // match" & @CRLF & _
"Howdy world? lorem // match" & @CRLF & _
"What is reality. howdy // match" & @CRLF & _
"Howdy you. Lorem // no match" & @CRLF & _
"Howdy you. 進撃の // no match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")