const regex = /[.!?]\s*[a-z]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[.!?]\\s*[a-z]', 'g')
const str = `Howdy world? lorem // match
Howdy world... lorem // match
Howdy world? lorem // match
What is reality. howdy // match
Howdy you. Lorem // no match
Howdy you. 進撃の // no match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}