package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[.!?]\s*[a-z]`)
var str = `Howdy world? lorem // match
Howdy world... lorem // match
Howdy world? lorem // match
What is reality. howdy // match
Howdy you. Lorem // no match
Howdy you. 進撃の // no match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}