import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.!?]\\s*[a-z]";
final String string = "Howdy world? lorem // match\n"
+ "Howdy world... lorem // match\n"
+ "Howdy world? lorem // match\n"
+ "What is reality. howdy // match\n"
+ "Howdy you. Lorem // no match\n"
+ "Howdy you. 進撃の // no match";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}