using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.!?]\s*[a-z]";
string input = @"Howdy world? lorem // match
Howdy world... lorem // match
Howdy world? lorem // match
What is reality. howdy // match
Howdy you. Lorem // no match
Howdy you. 進撃の // no match";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}