const regex = /^(?!.*\btime\b)[^.^\[\]{}\n]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\btime\\b)[^.^\\[\\]{}\\n]*$', 'gmi')
const str = `testtime -> allowed
testTime -> allowed
tim etest -> allowed
thetimetest -> allowed
the time test -> not allowed
test[my -> not allowed
my}test -> not allowed
test^time -> not allowed`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}