$re = '/^(?!.*\btime\b)[^.^\[\]{}\n]*$/mi';
$str = 'testtime -> allowed
testTime -> allowed
tim etest -> allowed
thetimetest -> allowed
the time test -> not allowed
test[my -> not allowed
my}test -> not allowed
test^time -> not allowed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);