re = /^(?!.*\btime\b)[^.^\[\]{}\n]*$/mi
str = 'testtime -> allowed
testTime -> allowed
tim etest -> allowed
thetimetest -> allowed
the time test -> not allowed
test[my -> not allowed
my}test -> not allowed
test^time -> not allowed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end