import re
regex = re.compile(r"^(?!.*\btime\b)[^.^\[\]{}\n]*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("testtime -> allowed\n"
"testTime -> allowed\n"
"tim etest -> allowed\n"
"thetimetest -> allowed\n"
"the time test -> not allowed\n"
"test[my -> not allowed\n"
"my}test -> not allowed\n"
"test^time -> not allowed")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")