using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.+(\bgoogle.com\b))(<a[^>]+href="")(http|https)([^>"" ]+)(""?[^>]*>)";
string input = @"<a href=""http://www.google.com"">google</a>
<a href=""http://www.exmple.com"">example</a>
<a href=""http://www.google.com"">google</a>
<a href=""http://www.exmple.com"">example</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}