const regex = /(?!.+(\bgoogle.com\b))(<a[^>]+href=")(http|https)([^>" ]+)("?[^>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.+(\\bgoogle.com\\b))(<a[^>]+href=")(http|https)([^>" ]+)("?[^>]*>)', 'gm')
const str = `<a href="http://www.google.com">google</a>
<a href="http://www.exmple.com">example</a>
<a href="http://www.google.com">google</a>
<a href="http://www.exmple.com">example</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}