import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.+(\\bgoogle.com\\b))(<a[^>]+href=\")(http|https)([^>\" ]+)(\"?[^>]*>)";
final String string = "<a href=\"http://www.google.com\">google</a>\n"
+ "<a href=\"http://www.exmple.com\">example</a>\n"
+ "<a href=\"http://www.google.com\">google</a>\n"
+ "<a href=\"http://www.exmple.com\">example</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}