$re = '/(?!.+(\bgoogle.com\b))(<a[^>]+href=")(http|https)([^>" ]+)("?[^>]*>)/m';
$str = '<a href="http://www.google.com">google</a>
<a href="http://www.exmple.com">example</a>
<a href="http://www.google.com">google</a>
<a href="http://www.exmple.com">example</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);