re = /(?!.+(\bgoogle.com\b))(<a[^>]+href=")(http|https)([^>" ]+)("?[^>]*>)/m
str = '<a href="http://www.google.com">google</a>
<a href="http://www.exmple.com">example</a>
<a href="http://www.google.com">google</a>
<a href="http://www.exmple.com">example</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end