# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\s)\w+(\(((?:[^()]+|(?1))*?)\))(\('.*?'\))?//g;t' <<< "{
foo( a(1) )
bar(1)('a')
foo( bar(1)('a') )
foo( bar(1)('a')('a') )('a')
}
"