import Foundation
let pattern = #"(?<=\s)\w+(\(((?:[^()]+|(?1))*?)\))(\('.*?'\))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
foo( a(1) )
bar(1)('a')
foo( bar(1)('a') )
foo( bar(1)('a')('a') )('a')
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)