use strict;
my $str = '{
foo( a(1) )
bar(1)(\'a\')
foo( bar(1)(\'a\') )
foo( bar(1)(\'a\')(\'a\') )(\'a\')
}
';
my $regex = qr/(?<=\s)\w+(\(((?:[^()]+|(?1))*?)\))(\('.*?'\))?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";