re = /(?<=\s)\w+(\(((?:[^()]+|(?1))*?)\))(\('.*?'\))?/
str = '{
foo( a(1) )
bar(1)(\'a\')
foo( bar(1)(\'a\') )
foo( bar(1)(\'a\')(\'a\') )(\'a\')
}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result