$re = '/(?<=\s)\w+(\(((?:[^()]+|(?1))*?)\))(\(\'.*?\'\))?/';
$str = '{
foo( a(1) )
bar(1)(\'a\')
foo( bar(1)(\'a\') )
foo( bar(1)(\'a\')(\'a\') )(\'a\')
}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;