#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\s*.*\$\s*..*\$\s*\|}\s*.*\s*,*"
Local $sString = "sometimes $so$ |} hello," & @CRLF & _
"life $good$ | } hello, " & @CRLF & _
"not $that$ |} hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")