using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*.*\$\s*..*\$\s*\|}\s*.*\s*,*";
string input = @"sometimes $so$ |} hello,
life $good$ | } hello,
not $that$ |} hello";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}