const regex = new RegExp('\\s*.*\\$\\s*..*\\$\\s*\\|}\\s*.*\\s*,*', 's')
const str = `sometimes \$so\$ |} hello,
life \$good\$ | } hello,
not \$that\$ |} hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}