package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\s*.*\$\s*..*\$\s*\|}\s*.*\s*,*`)
var str = `sometimes $so$ |} hello,
life $good$ | } hello,
not $that$ |} hello`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}