$re = '/\s*.*\$\s*..*\$\s*\|}\s*.*\s*,*/s';
$str = 'sometimes $so$ |} hello,
life $good$ | } hello,
not $that$ |} hello';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);