#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?x) #ignora isso é para aceitar multi linha e comentario" & @CRLF & _
"" & @CRLF & _
"^ # inicio" & @CRLF & _
"(?=.*?[a-z]) # procura por caracteres `a` atá `z` pelo menos 1" & @CRLF & _
"(?=(?:.*?\d){9}) # procura por 9 digitos " & @CRLF & _
"[a-z\d ]{12,} # tem que ter 12 digitos ou mais entre `a` e `z` numeros e espaços" & @CRLF & _
"" & @CRLF & _
"$ # fim" & @CRLF & _
""
Local $sString = "aeioa123rasdaer12311412s" & @CRLF & _
"a 1 2 3 4 a f e 4 6 9 a 1 2" & @CRLF & _
"falha Por Que so tem Letras e espaço" & @CRLF & _
"012345679PassaPorqueTemNumeros" & @CRLF & _
"444Pass4 3P0r que T3m L3tr4as numeros e espaco " & @CRLF & _
"012345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")