# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x) #ignora isso é para aceitar multi linha e comentario\n\n"
r"^ # inicio\n"
r"(?=.*?[a-z]) # procura por caracteres `a` atá `z` pelo menos 1\n"
r"(?=(?:.*?\d){9}) # procura por 9 digitos \n"
r"[a-z\d ]{12,} # tem que ter 12 digitos ou mais entre `a` e `z` numeros e espaços\n\n"
r"$ # fim\n")
test_str = ("aeioa123rasdaer12311412s\n"
"a 1 2 3 4 a f e 4 6 9 a 1 2\n"
"falha Por Que so tem Letras e espaço\n"
"012345679PassaPorqueTemNumeros\n"
"444Pass4 3P0r que T3m L3tr4as numeros e espaco \n"
"012345678901")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.