$re = '/(?x) #ignora isso é para aceitar multi linha e comentario
^ # inicio
(?=.*?[a-z]) # procura por caracteres `a` atá `z` pelo menos 1
(?=(?:.*?\d){9}) # procura por 9 digitos
[a-z\d ]{12,} # tem que ter 12 digitos ou mais entre `a` e `z` numeros e espaços
$ # fim
/mi';
$str = 'aeioa123rasdaer12311412s
a 1 2 3 4 a f e 4 6 9 a 1 2
falha Por Que so tem Letras e espaço
012345679PassaPorqueTemNumeros
444Pass4 3P0r que T3m L3tr4as numeros e espaco
012345678901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);