use strict;
my $str = 'aeioa123rasdaer12311412s
a 1 2 3 4 a f e 4 6 9 a 1 2
falha Por Que so tem Letras e espaço
012345679PassaPorqueTemNumeros
444Pass4 3P0r que T3m L3tr4as numeros e espaco
012345678901';
my $regex = qr/(?x) #ignora isso é para aceitar multi linha e comentario
^ # inicio
(?=.*?[a-z]) # procura por caracteres `a` atá `z` pelo menos 1
(?=(?:.*?\d){9}) # procura por 9 digitos
[a-z\d ]{12,} # tem que ter 12 digitos ou mais entre `a` e `z` numeros e espaços
$ # fim
/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}