#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)!pybot (.*?) "
Local $sString = "!pybot run ```" & @CRLF & _
"print("passionbaby")" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"" & @CRLF & _
"as" & @CRLF & _
"das" & @CRLF & _
"d" & @CRLF & _
"ad" & @CRLF & _
"as" & @CRLF & _
"d" & @CRLF & _
"as" & @CRLF & _
"d" & @CRLF & _
"" & @CRLF & _
"as" & @CRLF & _
"d" & @CRLF & _
"sa" & @CRLF & _
"das" & @CRLF & _
"d" & @CRLF & _
"sa" & @CRLF & _
"d" & @CRLF & _
"\` \`" & @CRLF & _
"```"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")