// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)!pybot (.*?) ").unwrap();
let string = "!pybot run ```
print(\"passionbaby\")
asd
asd
asd
as
das
d
ad
as
d
as
d
as
d
sa
das
d
sa
d
\\` \\`
```";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}