using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!pybot (.*?) ";
string input = @"!pybot run ```
print(""passionbaby"")
asd
asd
asd
as
das
d
ad
as
d
as
d
as
d
sa
das
d
sa
d
\` \`
```";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}